Website Inaccessible
Incident Report for Discord Extreme List
Resolved
This incident has been resolved.
Posted Nov 25, 2021 - 04:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 21, 2021 - 23:38 UTC
Investigating
We are currently investigating this issue.
Posted Nov 19, 2021 - 22:13 UTC
This incident affected: Website, LGBT Website, and API.