High volume of requests causing degraded performance and site outages

Incident Report for Discord Extreme List

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 12:36 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 23, 2025 - 11:38 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 23, 2025 - 11:37 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 23, 2025 - 11:37 UTC

Monitoring

We have identified the issue, implemented a fix, and are monitoring the result. Website and load balancer are both fully operational, but API remains at degraded performance.
Posted Apr 23, 2025 - 09:33 UTC

Update

We suspect that DEL suffered a DDoS attack, performance has improved so we will be marking all components as degraded as we continue to investigate and monitor the situation.
Posted Apr 23, 2025 - 08:57 UTC

Investigating

We are currently investigating this issue.
Posted Apr 23, 2025 - 08:42 UTC
This incident affected: Website, API and Kubernetes (Load Balancer).